I_Mapper continued



  • DaegonDaegon CanadaMember Posts: 89 ✭✭✭
    With the change the explorer rankings being reset cause of the old rooms being removed and all. I've decided to start making my own map with mudbot. Mostly to keep me busy and active, but mainly to bring up my score.

    I keep running into problems with mudbot though. Like if I'm mapping sometimes chameleon going off will make it think I changed rooms. Or moving from one room to another and a message sneaks in and it changes the room title to whatever the message was.

    Just those kind of things. So I've been reading up on C++ coding and I'm confident I can go into the code and change a few things and alter them. I even have the source code stuff so I know I'm looking at the right area. But my question is this.

    How do I go from changing the source code to implementing it with mudbot? I've tried changing a few things from the source code, saving, then loading the map but it didn't effect mudbot. I moved the source code into the mudbot folder then tried loading the map again and still nothing changed.... So how do I go about doing that?
    'Those that do not attempt are those with the least stories to tell.'
  • MissariMissari Member Posts: 208 ✭✭✭
    It's been a while since I looked at Citadel/mudbot but I'm p sure you'll have to compile the changes for them to take affect.
  • VaskarVaskar Member Posts: 57 ✭✭✭
    edited August 2016
    You'd have to recompile Mudbot from your modified source code for the changes to take effect. How you do this is pretty situational, so you'd have to post with more details for any real advice for that.

    However, there is a workaround for the issue you are describing. From what I remember from using Mudbot in Imperian, Mudbot determines what the roomnames are by the color they're displayed in. Changing the color of the room titles to something that isn't used anywhere else should eliminate false positives from other messages. There should be a setting somewhere in the mudbot `help stuff that sets what color roomnames are.
  • OisynneOisynne MaineMember Posts: 38 ✭✭
    Okay. Hi there. I don't know if Mudbot is still relevant, but I'm having trouble getting it to function... I have it downloaded, I start it up, and I log in with Mudlet and it just... Does nothing. It doesn't connect, it doesn't not connect, it says it's connecting and does nothing.

    Any ideas?
  • KillienKillien Member Posts: 38 ✭✭✭
    It has been a while since I used mudbot, but I do remember a few things required.

    You have to ensure you are connecting to "localhost" or "". Port is 123 by default. I believe you also have to ensure the configuration file or some such shows the default connection for localhost on that port is Aetolia.com port 23.

    You'll also need to ensure the mudbot is at least updated enough to support GMCP. Original mudbot supported ATCP, but pretty sure just about any modern incarnation of mudbot (especially if it was the one built for Aetolia) should already support GMCP. If not, you're going to have a lot of problems even attempting to use it as a proxy.

    Beyond those two things, I am unsure what could be the problem. Honestly, though, the in-game mapper is absolutely amazing if you're looking for a map. I do use it alongside the mudlet mapper for 'visual' - but overall, the in-game moves pretty dang fast. I suppose the biggest thing would be the support for travel items (wings/amulet etc) to get to places faster.

    Hope that helps some!
Sign In or Register to comment.